P3699R0R0
Rename `conqueue_errc`

Published Proposal,

This version:
http://wg21.link/P3699R0
Author:
Audience:
LEWG
Project:
ISO/IEC 14882 Programming Languages — C++, ISO/IEC JTC1/SC22/WG21

Abstract

This paper proposes to rename std::conqueue_errc to std::conqueue_state.

1. Revision History

This paper is the initial revision.

2. Introduction

The proposal for concurrent queues C++ Concurrent Queues (P0260) uses an enumeration to specify possible return states of some queue operations. This enumeration is called conqueue_errc as it was originally meant for exceptions. However, the concurrent queue proposal doesn’t propose it’s own exception class anymore, so the name is misleading.

3. Name Options

In initial revisons of P0260 the enumeration was called queue_op_state. But op_state has a specific meaning in S/R context that completely different.

Dropping the op gives us queue_state. To make it clear that it’s specific to concurrent queues we could also name it conqueue_state.

4. Proposal 1

Rename std::conqueue_errc to std::queue_state.

5. Proposal 2

Rename std::conqueue_errc to std::conqueue_state.

References

Informative References

[P0260]
C++ Concurrent Queues (P0260). URL: https://wg21.link/P0260